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[Abstract] Semi-quantitative immunohistochemistry (IHC) is a powerful method for investigating protein 

expression and localization within tissues that involves using software, such as the freely available Fiji 

(ImageJ), to conduct deconvolution and downstream analysis. Currently, there is lack of an integrated 

protocol that includes a detailed procedure on how to measure or compare protein expression. 

Publications that use semi-quantitative methods to ascertain protein expression often don’t provide 

enough details in their methods section, which makes it difficult for the reader to reproduce their data. 

The current protocol provides an example and detailed steps of conducting semi-quantitative analysis 

of IHC images using Fiji software. 
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[Background] Semi-quantitative immunohistochemistry (IHC) has been widely used for investigating 

protein expression and localization within tissues (Matkowskyj et al., 2000; Cregger et al., 2006; Taylor 

and Levenson, 2006; Braun et al., 2013; Fedchenko and Reifenrath, 2014; Bauman et al., 2016; Pike 

et al., 2017; Lu et al., 2018; Crowe et al., 2019), and various software and methods have been used in 

semi-quantiative IHC to conduct deconvolution and downstream analysis. Some methods require 

advanced coding/mathematical experience or the use of subscription-based software that may not be 

feasible for every scientist (Matkowskyj et al., 2000; Shu et al., 2016; Guirado et al., 2018). Fiji (ImageJ) 

is a freely available software (version 1.2; WS Rasband, National Institute of Health, Bethesda, MD). 

Publications using ImageJ for image quantification are often directed towards the creation of specific 

plugins for ImageJ or lack a step-by-step protocol (Varghese et al., 2014; Chen Y, 2017; Guirado et al., 

2018). However, there is no integrated protocol that includes a detailed but simple procedure of 

conducting such steps, including the use of ImageJ software. There are many open online forums where 

users post their questions about using Fiji ImageJ for image quantification purposes. This is often due 

to publications not providing sufficiently detailed methods sections, which makes it difficult for the reader 

to reproduce the data. It is also time-consuming for researchers who are not initially familiar with ImageJ 

software to figure out how to use this software. The current protocol provides an example for conducting 

semi-quantitative analysis of IHC images using ImageJ. 
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Equipment 
 

Computer Specifications: 

1. A 64-bit operating system that has Windows 7 or greater, Mac OS X 10.11 or greater, or Linux 

with kernel supporting GLIBC 2.14 and GLIBCXX 3.4.15 (typically kernels 2.6.39) 

2. NVIDIA graphics card (GeForce, Quadro, or Tesla) with CUDA capabilities 2.0 or greater, see 

https://developer.nvidia.com/cuda-gpus for more details 

3. Need up-to-date NVIDIA drivers (minimum version of 369) 

4. Any computer with Java-based operating system and Excel available 

 

Software 
 

1. Free ImageJ Fiji software (Johannes Schindelin, Albert Cardona, Mark Longair, Benjamin 

Schmid, and others, https://imagej.net/Fiji/Downloads), version 1.2 (no specific plugin was used) 

 

Procedure 
 

A. Staining of tissue using immunohistochemistry procedure 

1. Reference to the procedure used for the staining of cells for the IHC protocol can be found in a 

previously published manuscript (Crowe et al., 2019). 
2. Brief protocol for immunohistochemistry staining: 

a. Cut FFPE tissue blocks into 4 µm sections and mount on positively charged slides. 

b. Deparaffinize and rehydrate tissue. 

c. Retrieve antigen in buffer of choice (citrate buffer at pH 6 was used for this protocol). 

d. Block antigen with normal goat serum and incubate with primary antibodies (i.e., anti-

OATP1B1 for this protocol). 

e. Incubate with horseradish peroxidase (HRP)-conjugated secondary antibody and visualize 

by 3,3’-diaminobenzidine (DAB) to detect the protein of interest (OATP1B1 in the current 

protocol). 

f. Stain nuclei with hematoxylin. 

g. Hematoxylin and eosin (H&E) staining is not necessary for this protocol, but is useful when 

looking at the pathology of the tissue. 

 

B. Image exporting and saving 

The microscope should be set up correctly (i.e., white balanced) before acquiring new data for the 

ImageJ default values to work. Export and save the raw immunohistochemistry (IHC) 

immunohistochemistry images as a .tiff file format. Tiff format for images is preferred to prevent the 

loss of raw data and associated metadata. 
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C. Using Fiji for deconvolution of the IHC image. 

1. Download and open Fiji software. 

2. Click the “File” option and click “Open”. The IHC image will open up on the computer screen. 

3. Click on the IHC image to make the image active. 
4. Click the “Image” option and select “Color” > “Color Deconvolution.” 

5. A new pop-up Color Deconvolution window will show up. For IHC images stained with 3,3’-

diaminobenzidine (DAB) and hematoxylin (H), select the “H DAB” vector option. Leave “Show 

Matrices” and “Hide Legend” unchecked and click “Okay.” (Figure 1). 

 

 
Figure 1. Color Deconvolution Window. The Color Deconvolution Window will be used to 

separate the staining of the IHC image. The H DAB vector separates the IHC image into DAB 

staining (brown staining) for the protein of interest and Hematoxylin (H) staining for the nucleus. 

 

6. After selecting the H DAB option, three different images will pop up on the computer screen. 

Color 1 window represents only the Hematoxylin staining (blue/purple) and Color 2 window 

represents only the DAB staining (brown) (Figure 2). 

 

 
Figure 2. Deconvolution of IHC image. Separation of the IHC image into hematoxylin staining 

for the nuclei (Color 1) and DAB staining for OATP1B1 protein expression (Color 2) in 

hepatocytes within human liver tissue. Color 3 panel is for another staining, if applicable. For 

DAB and hematoxylin staining alone, the Color 3 panel can be eliminated. In DAB and 

Color 1 Color 2 Color 3

http://www.bio-protocol.org/e4610
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hematoxylin staining, as in current studies, a warning “X” is shown so that users understand that 

the amount of antibody staining (i.e., DAB staining) in this case cannot be mathematically 

quantified, as it is not stoichiometric. 

 

7. Exit out of the Color 3 window, as this will not be needed for the image analysis. 

 

D. Thresholding the DAB-stained IHC image 

1. Click on the DAB Color 2 image to activate it. DAB staining represents your primary antibody of 

interest. In this case, liver tissue was incubated with an OATP1B1 primary antibody, and the 

OATP1B1 expression is detected by DAB. 

2. Go to “Image” and select “Adjust” and “Threshold”. After selecting the threshold, the brown 

image is converted into a black and white binary mask image, where all the values above the 

threshold are converted and represented in white. The background is black. 

Note: A shortcut to threshold the image is achieved by pressing “Ctrl” + “Shift” + “T”. 

3. A new threshold window will pop up. The top bar indicates your minimum threshold value and 

the bottom bar indicates your maximum threshold value (Figure 3). 

 

 
Figure 3. IHC image pre-threshold. IHC image converted to black and white pixels prior to 

thresholding the image (A). The threshold pop up window pre-threshold indicates the baseline 

threshold values (B). 

 

4. Leave the minimum threshold value set at zero. 

5. Adjust the maximum threshold value so that the background signal is removed, without 

removing the true DAB signal (Figure 4A). This is an arbitrary value, since it is set by the user. 

The maximum threshold value should be tested for at least five images to obtain an average 

maximum threshold value. Once the maximum threshold value is chosen, this will be set for all 

future IHC images. The measured threshold will only remain relevant provided that the 

microscope acquisition settings (color balance, exposure time, magnification, light source, 

camera vendor, etc.) remain constant throughout future experiments. 

6. Once the maximum threshold image is set, click “Apply” on the threshold window. After clicking 

http://www.bio-protocol.org/e4610
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apply, the minimum and maximum threshold values will be 255 (Figure 4B). 

 

 
Figure 4. IHC image post-threshold. The background for the DAB staining in the IHC image 

was removed by adjusting the maximum threshold value (A). The minimum and maximum 

threshold values were set and applied (B). 

 

E. Quantifying the DAB signal area in the IHC image 

1. Go to “Analyze” and select “Set Measurements”. 

2. A “Set Measurement” pop up window will open. Select the “Area”, “Mean grey value”, and 

“Display Label” boxes, and leave all other boxes unchecked. “Area” will give the size of the IHC 

image. “Mean grey value” represents the quantified signal, and “Display Label” gives the 

information on the image name being quantified (Figure 5A). 

3. Select “Okay” in the Set Measurement window. These options only need to be set once for the 

first image, and will be remembered for all other future images measured. 

4. Go to “Analyze” and select “Measure”. 

Note: A shortcut for measuring the signal area is “CTL + M”. 

5. A “Results” window will pop up giving the name of the image (Label), size of the image (Area), 

and the average pixel intensity of the threshholded image as an indirect way to measure staining 

area (Mean) (Figure 5B). 

6. Export results for later by clicking File>Save, as to avoid copy/paste errors. 

7. Exit out of the Color 2 DAB-stained image. 
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Figure 5. Measurement of DAB staining. The Set Measurements window to choose the 

options for output of each IHC image is shown. The suggested options for output are highlighted 

with red boxes (A). The Results output window is shown in (B), and contains the name of the 

image (Label), area of the image (Area), and mean grey value intensity (Mean). 

 

F. Measuring the size of the nucleus 

1. Click on the Hematoxylin Color 1 image to activate it. 

2. Select the “Straight line” tool on the Fiji panel. 

3. Measure the length of a nucleus by drawing a line across the nucleus with the Straight line tool 

(Figure 6A). 

4. Go to “Analyze” and select “Measure”. 

5. A Results window will pop up with the diameter of the nucleus (“Length”) (Figure 6B). 

6. Measure ~10 different nuclei, using Steps F1–F5 in a representative IHC image, and take the 

average of these lengths to determine the average size of the nuclei. This serves as the average 

size of the nuclei for all IHC images from hereon. It should be done across multiple images if 

images are significantly different and represent multiple conditions. 
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Figure 6. Measurement of nuclei size. The raw IHC image stained with DAB for OATP1B1 

staining and hematoxylin for nuclei staining is used to measure the size of the nuclei. Using the 

straight-line tool, a line is drawn over the nucleus (A, white arrow pointing to yellow line). The 

distance of the line is measured by going to Analyze > Measure in the ImageJ Fiji toolbox panel. 

The Length (highlighted in red box) represents the diameter of the nucleus (B). 

 

G. Thresholding the hematoxylin-stained IHC image 

1. Click on the Hematoxylin Color 1 image to activate it. 

2. Go to “Image”, and select “Adjust” and “Threshold”. After selecting threshold, the blue/purple 

image is converted to a black and white image. 

3. Set the minimum threshold value to zero. 

4. Adjust the maximum threshold value so that the background signal is removed, without 

removing the true hematoxylin/nucleus signal. This is an arbitrary value, since the user sets it. 

The maximum threshold value should be tested for at least five images to get an average 

maximum threshold value. Once the maximum threshold value is chosen, this will be set for all 

future IHC images. 

5. Once the minimum and maximum threshold values for the image are set, click “Apply” on the 

threshold window. After clicking apply, the minimum and maximum threshold values will be 255. 

Of note, automatic thresholds are preferred, since manual thresholds must be adequately tested 

and kept constant for all other images in the experiment. 

 

H. Quantifying the hematoxylin/nucleus signal in the IHC image 

1. Select the Color 1 Hematoxylin image to activate it again. 

2. Go to “Process” and select “Binary” > “Watershed”. This action will split the nuclei that are joined 

together into multiple nuclei. 

3. Go to “Analyze” and select “Analyze Particles”. 

4. An “Analyze Particles” window will pop up giving multiple options (Figure 7A). 

a. Size (pixel^2): Set the size of the nuclei to the average nuclei size measured in Step F6 to 

infinity (i.e., 6–Infinity). 

http://www.bio-protocol.org/e4610
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b. Circularity: Leave it set at 0.00–1.00. 

c. Show: Leave it set to “Nothing”. 

d. Select “Summarize” and “Exclude on Edges” in the window. Summarize will give a summary 

of the particle’s measurements. Exclude on the edges means that nuclei on the outer edge 

of the image will not be included in the measurement. 

5. Select “Okay” on the Analyze Particles window, and a Summary window with the output will pop 

up (Figure 7B). The output data includes: 

a. Count indicates the number of nuclei in the IHC image. 

b. Total area indicates the total area of the nuclei in the image.  

c. Average area indicates the average size of the nuclei in the IHC image. 

6. Copy the results in the Summary window to the same excel file for later analysis. 

7. Exit out of the Color 1 Hematoxylin/Nuclei stained image. 

 

 
Figure 7. Quantification of nuclei in IHC image. To measure the number of nuclei in each 

IHC image, the Analyze Particle window pops up after selecting Analyze > Analyze Particles (A). 

The size of the particle measured is set to the average diameter of nuclei to infinity. The options 

to summarize and exclude on the edges are selected prior to clicking okay. The summarize 

option leads to the summarized output of the count, total area, and the average size of the nuclei 

particles in the IHC image (B). Exclude on the eges indicates that no nuclei particles will be 

included in the analysis. 

 

I. Semi-quantitative analysis of the IHC image 

1. Open the excel file containing the DAB and hematoxylin results outputted from the Fiji software. 

2. For each image, divide the Mean grey intensity value from Step E5 by the number of nuclei 

measured in Step H5. This value represents the area of DAB stain normalized to the number of 

nuclei. 

3. Take the average normalized area of DAB of for all IHC images for each sample/treatment, etc. 

to obtain an average and standard deviation values. 
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Data analysis 
 

Expression of OATP1B1 and OATP1B3 were compared in genotyped human liver tissue stained 

with OATP1B1 or OATP1B3 DAB staining and hematoxylin. Using 79 genotyped human liver IHC 

samples, there was no significant difference between the genotypes for OATP1B1 (c.521 TC) 

polymorphism using a Student’s t-test (Crowe et al., 2019).  

 

Application of this protocol to other studies should be done with caution, as it may not work for others 

if their microscope or staining protocols differ slightly, even if they were to imagestain the same 

protein with the same antibody. In addition, this protocol is not intended to replace the ImageJ manual, 

which is a great resource for users, and can be found at https://www.researchgate.net

/publication/260261544_Analyzing_fluorescence_microscopy_images_with_ImageJ or 

https://petebankhead.gitbooks.io/imagej-intro/content/chapters/rois/rois.html. 
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